Javafree
 Forum   Topics   Author   Post 
Java Básico Jboss erro ao subir aplicação thibalta Boa tarde, Estou com uma aplicação no Jboss que está usando um jar que fiz de outro projeto com minhas models. Quando add o jar no projeto ele não consegue mais "subir".. Será que alguém já passou por isso? segue o erro: [code] ` 16:29:09,245 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.deployment.unit."lk.war".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."lk.war".FIRST_MODULE_USE: JBAS018733: Falha ao proceder com a fase FIRST_MODULE_USE do deployment "lk.war" at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14] at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1] at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1] at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [rt.jar:1.8.0_45] at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.8.0_45] at java.lang.Thread.run(Unknown Source) [rt.jar:1.8.0_45] Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011434: Erro ao carregar o módulo do provedor de persistência org.eclipse.persistence (classe org.eclipse.persistence.jpa.PersistenceProvider) at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.lookupProvider(PersistenceUnitServiceHandler.java:613) at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.deployPersistenceUnit(PersistenceUnitServiceHandler.java:313) at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.addPuService(PersistenceUnitServiceHandler.java:275) at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.handleWarDeployment(PersistenceUnitServiceHandler.java:190) at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.deploy(PersistenceUnitServiceHandler.java:116) at org.jboss.as.jpa.processor.PersistenceBeginInstallProcessor.deploy(PersistenceBeginInstallProcessor.java:48) at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14] ... 5 more Caused by: org.jboss.modules.ModuleNotFoundException: org.eclipse.persistence:main at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:240) [jboss-modules.jar:1.3.0.Final-redhat-2] at org.jboss.as.jpa.persistenceprovider.PersistenceProviderLoader.loadProviderModuleByName(PersistenceProviderLoader.java:60) at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.lookupProvider(PersistenceUnitServiceHandler.java:610) ... 11 more 16:29:09,277 INFO [org.jboss.as.server] (ServerService Thread Pool -- 29) JBAS018559: Implantado "lk.war" (runtime-name: "lk.war") 16:29:09,277 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Relatório de status de serviço JBAS014777: Serviços que falham na inicialização: service jboss.deployment.unit."lk.war".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."lk.war".FIRST_MODULE_USE: JBAS018733: Falha ao proceder com a fase FIRST_MODULE_USE do deployment "lk.war" 16:29:10,151 INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: A interface do gerenciamento ouvindo no http://10.50.1.82:9990/management 16:29:10,151 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: O console de administração ouvindo no http://10.50.1.82:9990 16:29:10,151 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.2.0.GA (AS 7.3.0.Final-redhat-14) iniciado (com erros) em 6854ms - Iniciado 166 de serviços 250 (1 serviços falharam ou faltam dependência, os serviços 77 são passivos ou em demanda) [/code]
Java Básico imagem não carregada quando executo o jar thibalta Sim.. pois quando eu abro o jar com o wirrar ele aparece a pasta com as imagens dentro..
Java Básico imagem não carregada quando executo o jar thibalta Ola bom dia a todos, Estou com uma alicação onde tenho que carregar uma imagem. Quando abro minha aplicação pelo netbeans da certo, mas quando eu limpo e construo ele e tento executar o jar as imagens não aparecem.... Eu tento pegar a imagem assim: (Um exemplo que vi na net..) [code] icon = new ImageIcon(this.getClass().getResource("/ImagensAprenderLetras/LAprender.png")); new MostraAprenderView(icon); [/code] Funciona quando compilo, mas não pelo jar la.. obrigado... :)
Java Básico Calculo Variavel Time thibalta Boa tarde, Sou iniciante em java e não consigo resolver esse problema.. Estou com um problema de calcular a diferença de tempo de duas variáveis. Time horaSaida Time horaEntrada a entrada é 12:00:00 a saida é 13:00:00 Como a diferença de tempo? 13:00:00 - 12:00:00 = 1:00:00 ? (Não usei Date, pois preciso apenas da horas e minutos e segundos).. Obrigado :)
Java Básico Tela não Abre :( thibalta Boa Tarde.. Sou iniciante em Java e preciso de ajuda. Estou com problemas em abrir uma nova tela. eu criei um Jframe onde neste frame tem um JmenuBar que tem um Jmenu que tem um JmenuItem. (Objetivo era criar akeles menuzinhos de cadastros) No JmenuItem eu adicionei um evento de "ActionPerformed". Fico assim: [code] private void itemMenuCadastrarActionPerformed(java.awt.event.ActionEvent evt) { new cadastroView(); } [/code] ele chama um construtor de JinternalFrame: [code] public cadastroView() { initComponents(); this.setSize(1200, 600); this.setEnabled(true); this.setVisible(true); this.toFront(); } [/code] Mas quando executo e cliko no menu nada acontece. A segunda tela de cadastro não aparece. O que estou fazendo de errado? Obrigado :D
Goto page 1