Javafree
Página Inicial do Fórum > Java Básico

Problema com o printf



Criar novo tópico   Responder tópico


  1. jotaerre
    Posts:1


    Comment Arrow

    Publicado em: 19/09/2011 15:28:17

    Eu estou com um problema no mesmo programa. So q no meu caso, o printf nao funciona de jeito nenhum. Esse codigo eu copiei de um livro.

    Aparece essa mensagem de erro:

    Exception in thread "main" java.lang.Error: Unresolved compilation problem:
    The method printf(String, Object[]) in the type PrintStream is not applicable for the arguments (String, int)

    at Adittion.main(Adittion.java:25)

    [/code]



  1. sekkuar
    Posts:5998


    Comment Arrow

    Publicado em: 19/09/2011 15:40:35

    Isso que dá usar o eclipse antes de saber programar!

    Se você estivesse programando no bloco de notas, e compilando manualmente, achava o problema facinho.
    _________________

    Sekkuar ~ Ex-Catador Executivo do Javafree - (Não mais) Catando os tópico tudo.
    "The mod javafree deserves, but not the one it needs right now."

    Stack Traces existem pra ajudar e não para trazer uma mensagem de satã dizendo que seu computador será destruído.


    Peça seu Código Pronto para o seu Dever de Casa aqui
    You acknowledge that this software is not designed, licensed or intended for use in the design, construction, operation or maintenance of any nuclear facility.



  1. simu
    Posts:9417


    Comment Arrow

    Publicado em: 19/09/2011 16:59:35

    O erro "The method printf(String, Object[]) in the type PrintStream is not applicable for the arguments (String, int)" indica que o compilador não está configurado para compilar Java 1.5 ou maior.

    Window -> Preferences -> Java -> Compiler

    "Compiler compliance level" tem que ser 1.5 ou maior. O mesmo vale para as duas opções segunites se o "Use default compliance settings" estiver desativado.

    [[]]
    _________________

      Nome real: Carlos F. Heuberger

    Removeram os meus direitos de administrador e moderador - sem aviso, pela segunda vez - contate o ombudsman (?), a equipejavafree ou a "alta gerência" se necessário - Que pena... que terminou dessa maneira!

    "The mod javafree deserves, but not the one it needs right now."
    --------------------
    Não leio nem respondo MPs!
    This posting is provided AS IS with no warranties and confers no rights.

  1. Comment Arrow

    Publicado em: 10/08/2016 19:27:57

    [quote="simu"]O erro "The method printf(String, Object[]) in the type PrintStream is not applicable for the arguments (String, int)" indica que o compilador não está configurado para compilar Java 1.5 ou maior.

    Window -> Preferences -> Java -> Compiler

    "Compiler compliance level" tem que ser 1.5 ou maior. O mesmo vale para as duas opções segunites se o "Use default compliance settings" estiver desativado.

    [[]]



    Como posso resolver esse impasse?



  1. Relacionados