Javafree
Página Inicial do Fórum > Frameworks, APIs e IDE's

Entidade perdendo o valor do id



Criar novo tópico   Responder tópico


  1. altagnam
    Posts:38


    Comment Arrow

    Publicado em: 10/07/2014 22:59:30

    Salve galera!! Baum de mais!?

    Vamos lá.. estou com um probleminha chato para resolver.. preciso da ajuda de vocês..

    Então.. o negócio é o seguinte.. O atributo ID (tipo Long) das pesquisas realizadas estão vindo nulos...

    Exemplo:
    Cliquei em botão... este botão chama uma função que retornará uma lista de objetos.. Dentro de cada objeto tem o atributo ID... No momento que inspeciono a lista de resultados, vejo que este atributo (ID) esta nulo...

    Debuguei e ví que dentro do meu EJB (onde faço a pesquisa) o valor do ID está preenchido corretamente mas quando ele chega no MB já fica nulo!!

    Ahh.. isto acontece somente quando eu faço um lookup no meu EJB.. se acessar utilizando a injeção de dependência do JBoss 7.1 o atributo ID vem preenchido...

    Alguém tem alguma ideia?
    _________________

    ALTAGNAM



  1. D3z40
    Posts:1530


    Comment Arrow

    Publicado em: 10/07/2014 23:17:32

    [quote="altagnam"]Salve galera!! Baum de mais!?

    Vamos lá.. estou com um probleminha chato para resolver.. preciso da ajuda de vocês..

    Então.. o negócio é o seguinte.. O atributo ID (tipo Long) das pesquisas realizadas estão vindo nulos...

    Exemplo:
    Cliquei em botão... este botão chama uma função que retornará uma lista de objetos.. Dentro de cada objeto tem o atributo ID... No momento que inspeciono a lista de resultados, vejo que este atributo (ID) esta nulo...

    Debuguei e ví que dentro do meu EJB (onde faço a pesquisa) o valor do ID está preenchido corretamente mas quando ele chega no MB já fica nulo!!

    Ahh.. isto acontece somente quando eu faço um lookup no meu EJB.. se acessar utilizando a injeção de dependência do JBoss 7.1 o atributo ID vem preenchido...

    Alguém tem alguma ideia?



    Posta trecho do código onde você faz a atribuição dos valores recuperados no objeto.
    _________________

    Para organização do fórum sempre poste suas dúvidas no TÓPICO que mais se encaixa com o real problema da dúvida.

    Por favor, nunca esqueça de editar os códigos de seu post com as tag CODE.



  1. altagnam
    Posts:38


    Comment Arrow

    Publicado em: 10/07/2014 23:42:35

    Construtor do Paginador:



    Aqui em baixo ele faz a pesquisa:




    Aqui em baixo ele processa a pesquisa:




    Se inspecionar a variável "retorno" da função executar os ID's estão preenchidos..

    Já na hora de visualizar os dados da lista na função load, os ID's estão nulos!!
    _________________

    ALTAGNAM



  1. Relacionados