Javafree
Página Inicial do Fórum > Java Básico

PASSAR DE VISUAL G PRA JAVA



Criar novo tópico   Responder tópico
  1. Comment Arrow

    Publicado em: 04/05/2016 22:31:58

    Amigos, boa noite!!
    Estou precisando converter um programa criado no visual g para Java.
    Alguém pode me ajudar??

    algoritmo "Concreto"

    var

    p,c,a,v, cmf,vt,n,arf, pef, qcf, traco,cm,ar,pe,ag, cb,agf, qc, resto: real

    Cmi, Ari, pei, agi, qci, l : inteiro

    inicio

    Escreval ("Entre com a profundidade, comprimento e altura respectivamente"

    Leia (p,c,a)

    v <- p*c*a

    vt <- v*1.1

    Escreval (" O volume necessário de concreto é:",v)

    Escreval ("Considerando o fator de segurança de 10%"

    Escreval (" O volume do concreto total é :", vt)

    Escreval ("Escolha a finalidade do concreto:"

    Escreval (" 1 para fundações; 2 para pisos; 3 para pilares, vigas, lajes e pré moldados em geral"

    Leia (l)

    escolha (l)

    Caso 1

    traco <- 0.16

    n<- vt/traco

    cm <- n*1

    cmi <- int(cm) + 1

    resto <- cmi - cm

    se resto = 1 entao

    cmf <- cm

    senao

    cmf<- cmi

    fimse

    ar <- n*8.5

    ari <- int(ar) + 1

    resto <- ari - cm

    se resto = 1 entao

    arf <- ar

    senao

    arf<- ari

    fimse

    pe <- n*11.5

    pei <- int(pe) + 1

    resto <- pei - pe

    se resto = 1 entao

    pef <- pe

    senao

    pef<- pei

    fimse

    ag <- n*2

    agi <- int(ag) + 1

    resto <- agi - ag

    se resto = 1 entao

    agf <- ag

    senao

    agf<- agi

    fimse

    escreval (" O traço necessario é:"

    escreval (cmf,"saco(s) de cimento"

    escreval (arf, "lata(s) de areia"

    escreval (PEf,"lata(s) de pedra"

    escreval (agf, "lata(s) de água"

    caso 2

    traco <- 0.14

    n<- vt/traco

    cm <- n*1

    cmi <- int(cm) + 1

    resto <- cmi - cm

    se resto = 1 entao

    cmf <- cm

    senao

    cmf<- cmi

    fimse

    ar <- n*4

    ari <- int(ar) + 1

    resto <- ari - cm

    se resto = 1 entao

    arf <- ar

    senao

    arf<- ari

    fimse

    pe <- n*6

    pei <- int(pe) + 1

    resto <- pei - pe

    se resto = 1 entao

    pef <- pe

    senão

    pef<- pei

    fimse

    ag <- n*1.5

    agi <- int(ag) + 1

    resto <- agi - ag

    se resto = 1 entao

    agf <- ag

    senão

    agf<- agi

    fimse

    escreval (" O traço necessario é:"

    escreval (cmf,"saco(s) de cimento"

    escreval (arf, "lata(s) de areia"

    escreval (PEf,"lata(s) de pedra"

    escreval (agf, "lata(s) de água"

    caso 3

    traco<- 0.14

    n<- vt/traco

    cm<- n*1

    cmi <- int(cm) + 1

    resto <- cmi - cm

    se resto = 1 entao

    cmf <- cm

    senao

    cmf<- cmi

    fimse

    ar <- n*4

    ari <- int(ar) + 1
    resto <- ari - cm
    se resto = 1 entao
    arf <- ar
    senao
    arf<- ari
    fimse
    pe <- n*5.5
    pei <- int(pe) + 1
    resto <- pei - pe
    se resto = 1 entao
    pef <- pe

    senao
    pef<- pei
    fimse

    ag <- n*1.25

    agi <- int(ag) + 1

    resto <- agi - ag
    se resto = 1 entao
    agf <- ag

    senao

    agf<- agi

    fimse

    escreval (" O traço necessario é:"

    escreval (cmf,"saco(s) de cimento"

    escreval (arf, "lata(s) de areia"

    escreval (PEf,"lata(s) de pedra"

    escreval (agf, "lata(s) de água"

    outrocaso
    escreval (" Opção inválida"

    fimescolha

    Escreval (" Informe quantos m³ a caçamba do caminhão suporta:"

    Leia (cb)

    qc <- VT/cb
    qci <- int(qc) + 1
    resto <- qci - qc
    se resto = 1 entao
    qcf <- qc
    senao
    qcf<- qci
    fimse
    Escreval (" A quantidade de caminhão(s) é:", qcf)
    fimalgoritmo
    _________________

    Att.,

    Carlos Filho



  1. Relacionados